09 Whiplash Snowflake 1450 winner incar cam

AZmxer

Well-Known Member
Posts
286
Reaction
11
This is from the first two laps then the camera dies. Got some good action except for 25mph off the start cause we did not know it was lifted for the first lap!! oops!

The file was damaged and would not play so I had to download a free converter to repair the AVI file so there is a watermark in a few spots on the clip:(

Thanks to Brad the TT winner for paying up on the $100 side bet for fastest lap Dinner was great !thanks ha ha

Also thanks to my Sponsors FST Motorsports, BFG tires, and Enviro/Lube Express

Always a great time at this race and cant wait till next year


[ame="http://www.youtube.com/watch?v=6wCuRb5K9M0"]YouTube - 2009 Whiplash Snowflake 1450 winner incar cam[/ame]
 

RTE Kidd

Member
Posts
18
Reaction
0
Truck looked awsome Kevin and by all accounts you drove a great race. Congrats!! Maybe someday I'll finish mine and get to have some fun too.
 

KGM Racing

Well-Known Member
Posts
200
Reaction
30
Congrats on the Win!!! Truck looks good. Sucks we couldnt make it this year. What does your truck top out now with the big motor up on the meadow flats?
 

LC Offroad Racing

Well-Known Member
Posts
251
Reaction
10
Looks like that truck should be racing in 1400 you where smoking the rest of the feild
 

esbyota

Well-Known Member
Posts
422
Reaction
6
No wait, I'm the winner!
 

AZmxer

Well-Known Member
Posts
286
Reaction
11
Truck looked awsome Kevin and by all accounts you drove a great race. Congrats!! Maybe someday I'll finish mine and get to have some fun too.
Thanks!! keep going its worth it

Congrats on the Win!!! Truck looks good. Sucks we couldnt make it this year. What does your truck top out now with the big motor up on the meadow flats?

Thanks!! fastest we got was 104MPH this race. we were only 30 seconds slower than Shannon Campbell fastest lap time. Not bad for a 1450 truck


Looks like that truck should be racing in 1400 you where smoking the rest of the feild

Whiplash does not have a 1400 class so just like BAP we all run 1450. We race 1400 in MDR and just won the Cali 200 night race and 3rd O/A


No wait, I'm the wiener!

What ever you say Brad!!
 

LC Offroad Racing

Well-Known Member
Posts
251
Reaction
10
Thanks!! keep going its worth it




Thanks!! fastest we got was 104MPH this race. we were only 30 seconds slower than Shannon Campbell fastest lap time. Not bad for a 1450 truck





Whiplash does not have a 1400 class so just like BAP we all run 1450. We race 1400 in MDR and just won the Cali 200 night race and 3rd O/A





What ever you say Brad!!
Yeah looks like you guys fly what motor in that thing?
 

RBFJeep

Well-Known Member
Posts
465
Reaction
9
Great Video! It was fun to see you pass our wives that were racing our truck at this race.

You were defintely on it.
 

Rock Donkey

Well-Known Member
Posts
441
Reaction
41
This is from the first two laps then the camera dies. Got some good action except for 25mph off the start cause we did not know it was lifted for the first lap!! oops!

The file was damaged and would not play so I had to download a free converter to repair the AVI file so there is a watermark in a few spots on the clip:(
Finally got our video uploaded from the first lap (camera also died). My cheapo in-car camera had about the same wind noise so I added some tunes to cover it up!

Oh, and I think our station wagon passed you at 1:50 in the vid. :p

[ame="http://www.vimeo.com/7550993"]Snowflake150 Race Jeepspeed in-car video on Vimeo[/ame]
 

scottm

Well-Known Member
Posts
1,864
Reaction
509
Wow, you did fast laps considering you had to pass so much traffic. What was the fastest you hit on the power line road?
 

Rock Donkey

Well-Known Member
Posts
441
Reaction
41
Wow, you did fast laps considering you had to pass so much traffic. What was the fastest you hit on the power line road?
I didn't think our lap times were that fast. 36 or 37 min. per lap? Not sure what speed we hit on the power line road, but I remember our top speed on the flat fast section was 72 on the GPS. Gearing and motor were to blame (stock 4.0L with 6.13 gears in the axle).
 

scottm

Well-Known Member
Posts
1,864
Reaction
509
Oops, sorry, I was meaning to ask that of AZmxer!
 

AZmxer

Well-Known Member
Posts
286
Reaction
11
Finally got our video uploaded from the first lap (camera also died). My cheapo in-car camera had about the same wind noise so I added some tunes to cover it up!

Oh, and I think our station wagon passed you at 1:50 in the vid. :p
Cool video !! You definatly got the memo about the speed limit!!:D Although that was not us you passed then. I tried some songs but youtube kept deleting them:(
Wish we could race there more!!

Wow, you did fast laps considering you had to pass so much traffic. What was the fastest you hit on the power line road?
Im not sure.. I never look cause its way on the other side. I do set it to record for top speed each race. Im guessing 50-60mph ??
 
Top