99 GMC 1500 4wd problem

FullsizeFun

Well-Known Member
Joined
Mar 30, 2004
Posts
411
RDC Crypto
6
Location
South Bay, Redondo Beach
I have a 99 Z71 and when i try to put it in 4wd the message comes up on the dash and says "service 4wd", not too helpfull. It gets stuck in 4wd and will only come out if i disconnect the battery.
I normally dont ask questions like this without doing more investigating for myself, but i figured this is a common problem and somebody would have a quick answer.
 

gawdodirt

Well-Known Member
Joined
May 22, 2003
Posts
387
RDC Crypto
50
Location
Gilbert, AZ
Whoa! Before you go through that, it's a either a recall or bulletin for free replacement. So go get a new switch.
Known issue...

GD
 

EASTCOAST DUKE

Well-Known Member
Joined
Aug 18, 2007
Posts
144
RDC Crypto
4
Location
LUDLOW,MA.
I have a 99 chevy silverado with a similar prob,My service 4wd message comes on
while driving in 2wd,and i had probs shifting in and out of 4wd this winter!!!
Do you have the push buttons with autotrac???Ithink my prob is that my transaxle
is leaking oil out the rear seal,and level is low!!!Does anyone know how envolved
and expensive this fix is???
 

FullsizeFun

Well-Known Member
Joined
Mar 30, 2004
Posts
411
RDC Crypto
6
Location
South Bay, Redondo Beach
Mine is now stuck in 4hi and wont come out. it used to go back to 2wd if i disconnect the battery now it doesnt. I can hear the actuators on the diff and t-case trying to do something, but it just wont come out. I think the control module on the dash is OK because the actuators seem to be getting the signal. but the "service 4wd" light isn't coming on any more jajaja.
 
Top