FORD P0171 trouble code

cancinoj

Well-Known Member
Posts
842
Reaction
29
our ford 4.0 sohc engine runs great from 3000 rpms and up on our first test drive, and idles rough sometimes and from idle to 3000 missfire or backfier a lot, so, we thougth that was normal because it was our first time with that engine, it looks like it is not, we did a scan yesterday and that trouble code came up, P0171, that is, LEAN MIXTURE ON BANK 1, been googleing for answers and on all the forums they came up with the same answer, vaccum problems or air leaks, that on most of the cases, this sohc engines have that kind of problem from what i heard from ford guys, i will start replacing the lower and upper intake gaskets and replace the o2 sensor of that side, and will see what happens,

so, how did you fixed that problem? what was your solution,. am i right, or is something else to look for.,. thks.

the pic is just for fun, it was from yesterday testing.
 

cancinoj

Well-Known Member
Posts
842
Reaction
29
i did some test to the maf sensor and the book said that it should read .4 to .7 volts at iddle and 1.5 to 3 or 5 volt when accelerating, ours did 1.5v at iddle , so, that's out of range but if that was the case a trouble code could came up because of that right?
 

cancinoj

Well-Known Member
Posts
842
Reaction
29
on our 302 we had similar problems from craked fuel injectors. just an idea.

yes good idea, found on different forum that a guy with same trouble code and ford just replaced a cloged fuel injector, we will replaced the injectors from that side of the engine,. will do that today.
 

F1shifty

Well-Known Member
Posts
59
Reaction
1
injectors aint cheap!! try the basics first, spray carb and choke around the intake gaskets, check fuel pressure, clean MAF...not with carb n choke, ive seen it destroy them beofre. im sure you know fords are notorious for maf problems. if your scan tool is capable check fuel trims. and before you start throwing injectors at it if your not sure take it to a shop! good luck
 

cancinoj

Well-Known Member
Posts
842
Reaction
29
injectors aint cheap!! try the basics first, spray carb and choke around the intake gaskets, check fuel pressure, clean MAF...not with carb n choke, ive seen it destroy them beofre. im sure you know fords are notorious for maf problems. if your scan tool is capable check fuel trims. and before you start throwing injectors at it if your not sure take it to a shop! good luck

we already replaced all the intake gaskets, now no vaccum leaks, replaced o2 sensor, the problem still there,. the symptoms are the same, i know fuel injectors can be serviced, we will do that, i did some test on the fuel injectors, well, i disconnect the fuel injector #1 with the engine at idle and the difference was verely noticed, rough idle, tryied with fi #2 and the engine shutdown easy, did the same with fi#3 and same result as fi #1, what do you think about that?

the facts: the engine works ok at WOT, it idles rough sometimes and sometimes it works smoth, fuel pressure is 40psi , with fuel regulator on goes to 30psi, so i disconnected the fuel pressure regulator to keep the pressure at 40psi. this is a 98 ford 4.0 sohc, and the P0171 trouble code. :mad:
we will put a high pressure fuel pump to see if that is the problem,.
 

DSRacing

Mini Metal MOD
Posts
3,448
Reaction
351
injectors aint cheap!! try the basics first, spray carb and choke around the intake gaskets, check fuel pressure, clean MAF...not with carb n choke, ive seen it destroy them beofre. im sure you know fords are notorious for maf problems. if your scan tool is capable check fuel trims. and before you start throwing injectors at it if your not sure take it to a shop! good luck

Agreed, The injectors for the SOHC are expensive. Clean the Mass Air with plain old isopropyl alcohol and a Q-tip. What kind of fuel filters are you using? We had a similar problem (bad low end power) when we ran a single 100 micron filter before the fuel pump. The truck would run fine for about a half an hour before the injectors would start clogging up. We installed an additional 10 micron canister type filter after the fuel pump and the problem went away.
 

cancinoj

Well-Known Member
Posts
842
Reaction
29
Agreed, The injectors for the SOHC are expensive. Clean the Mass Air with plain old isopropyl alcohol and a Q-tip. What kind of fuel filters are you using? We had a similar problem (bad low end power) when we ran a single 100 micron filter before the fuel pump. The truck would run fine for about a half an hour before the injectors would start clogging up. We installed an additional 10 micron canister type filter after the fuel pump and the problem went away.

we had a cheap fuel filter before the fuel pump, it was old and dirty, we took out that filter and just put a new stock fuel filter after the fuel pump, pressure was the same, so, maybe the fuel injectors are already clogged, will take'm out today ,. didn't test the maf yesterday after installing new intake gaskets to see if it works by the book,. as i said before, i did test the maf and it was out of range at idle, 1.5 v at idle when it should ready .4 to .7v,
 

DSRacing

Mini Metal MOD
Posts
3,448
Reaction
351
The injectors have a tiny screen built into them When you pull the injector, take a paper towel and lay it flat on a table, turn the injector upside down and tap it on the towel. You will see the debris leave dark rings. I then give it a small shot of brake cleaner and continue tapping the injector until it doesn't leave any rings on the paper towel. I was able to salvage a couple of injectors this way.
 

cancinoj

Well-Known Member
Posts
842
Reaction
29
we just replaced all the injectors and so far it sounds smoth, didnt had the time to test it on the street, but so far is sounds ok,. will cross my fingers for that to be the problem,. will see.
 

cancinoj

Well-Known Member
Posts
842
Reaction
29
this was from last sunday, doing some testing to the video system,. that was the only part with good audio,. the rest of the video sounds like the end of this one.
 
Last edited by a moderator:
Top