Leaky A4LD

BIG_FAT_LOSER

Well-Known Member
Posts
1,533
Reaction
3
92 2wd explorer. Mine is pukeing atf out of the bellhousing area when hot. Does not happen all the time, about once a month, but has been becoming more frequent. At idle or while driving, while in neutral or in drive but stops when engine is off. Anyone have experience with this happening? Trans was replaced under warranty over a year ago (by used car dealer). Possible front seal damage (at converter) from them ramroding it back together? Just looking for clues before I get covered in atf.

Duct tape is like the Force.It has a light side and a dark side,and it holds the universe together.
 

scott

Well-Known Member
Posts
1,460
Reaction
1
My buddies ranger had the same problem when running the washes in San Felipe.... Trans got hot and puked it out the trans, were the Motor and Trans bolt up together. He just added ATF and kept going.... After the trans cooled, it was fine....
 

Ryno

Well-Known Member
Posts
1,230
Reaction
33
Pat-

your problem sounds like exactly what I had on my chevy about a month ago. Mine was due to a cracked hub on the converter. I had them replace the front pump seals as well. Not a fun job, but fairly easy with a 2wd. Lemme know if you want a hand...I'm right down the street.

Ryno

Build it like a Rhino, and Leave it be.
 

BIG_FAT_LOSER

Well-Known Member
Posts
1,533
Reaction
3
Thanks for the second opinions. looks like a new front pump seal and coverter ect in my future. May do it next weekend.

Duct tape is like the Force.It has a light side and a dark side,and it holds the universe together.
 
Top