Possible carb problems?

racechase01

Well-Known Member
Posts
167
Reaction
13
I hope there are some good Ford mechanics on today. I have an '84 Bronco with a 302 2bl carb. It idles fine, but under acceleration it sputters and backfires and barely moves. I opened up the carb and checked the float and took out the jets and cleaned it all with carb cleaner. I also tried advancing and retarding the timing and replacing the fuel filter. None of this helped. Here is the strange part, about 2 weeks ago I had the same problem. I tried all of the above and nothing helped. After I put the timing back where it was I drove it and it was fine.

Since then I have probably put 500 miles on it. Now all of a sudden the same problem, it started to do it a little and has gotten worse over the past 3 days. Oh, also it has a new (3mo.) distributor, dist cap, rotor, plugs and wires.

HELP......

PS. it does not have a cat. and it has a recent flowmaster muff.
 

matt_helton

Racer
Posts
3,876
Reaction
300
have you checked the fuel pressure??? is it an electric or manual fuel pump.?? id also check the fuel pressure regulator. and make sure vacume lines are intact. its also possible you have an ignition module problem. and its also possible (if it has high mileage) that the timing chain could be stretched/worn enough to jump a tooth. top dead #1 and make sure everything lines up.
 

racechase01

Well-Known Member
Posts
167
Reaction
13
It is a stock manual fuel pump and yes it does have high mileage. If the timing chain jumped a tooth, the problem wouldn't have gone away for a couple of weeks.

I have not checked the fuel pressure regulator so I will do that. I will also have to look into the ign. module also. Thanks for the help.

Any more input would be much appreciated.
 
Top