RZR Speedo issue

Avery stewart

New Member
Joined
Mar 3, 2020
Posts
2
RDC Crypto
1
Location
Fillmore ca
After two days of pre-running in San Felipe, my are RZR speedometer needle started fluctuating and killing the ignition. When going approximately 40 miles an hour the needle would drop to 10 and then immediately go up to 100 kill the ignition and when the needle drop back down to around 40 the ignition would come back on. Has anybody ever run across this type of problem on there RZR?
 

dzrt performance

Well-Known Member
Joined
Jan 31, 2014
Posts
166
RDC Crypto
107
your speedo most likely isnt the problem. this is an electrical issue with the engine. possibly a bad crank sensor where the engine loses the signal for a moment. the tach fluctuations are because the engine isn't sure what the RPM really is from the loss of signal from the crank. could be a bad sensor or connection to the sensor.
 

Duel Offender

Member
Joined
Jan 29, 2018
Posts
12
RDC Crypto
8
Location
Ventura Co
your speedo most likely isnt the problem. this is an electrical issue with the engine. possibly a bad crank sensor where the engine loses the signal for a moment. the tach fluctuations are because the engine isn't sure what the RPM really is from the loss of signal from the crank. could be a bad sensor or connection to the sensor.
Thanks for the response. Ordered a new speed sensor along with a new ignition switch. The ignition switch got hammered with mud and gunk and I couldn't tell because it was so for under the dash. It was from a couple of years ago when it rained for about a week straight before the 1000. Hopefully with those two items and cleaning up multiple connections, Problem Solved.
 
Top