• Forum membership has its advantages....

STELLA EVO

chino

Well-Known Member
Hi guys we received our upgrade kit for the STELLA and yesterday we tried to install it, but we have doubts on wich wire is the ground because on the old one the black wire was the ground and the new one doesnt have a black wire .

I already search for a YouTube tutorial to do this but no luck finding one, any help would be apreciated it, thanks in advance, see you guys at the race.
 
Last edited:

chino

Well-Known Member
This is the new one we received, as you can see there is no black wire wich was the one that worked as ground.

On the new one as you can see in the picture there is no black wire, that is the reason of my post

If the mods think that this post doesnt belong here, please redirect, thanks
 

johndjmix

Well-Known Member
If only the world started standardizing black for ground in automotive applications.

Usually it’s black. Sometimes white as pointed out. And... (most of you know the other half of my company sells scooter parts), some of the scooter world has decided to use blue for ground.

Urgh!

My race truck, wired by me, any black wire is ALWAYS ground.

—John
 

chino

Well-Known Member
If only the world started standardizing black for ground in automotive applications.

Usually it’s black. Sometimes white as pointed out. And... (most of you know the other half of my company sells scooter parts), some of the scooter world has decided to use blue for ground.

Urgh!

My race truck, wired by me, any black wire is ALWAYS ground.

—John
That is why it was confusing to us because on the other Stella the Black wire was ground, the positive side of it is that upgrade is ready to go, and we dont have to wait to do this in Ensenada and is 1 thing less to worry about .
 
Top