Toyota V6 Engine Help!

fishd00d

What A Joke
Joined
May 9, 2001
Posts
15,640
RDC Crypto
6,248
Location
San Marcos, CA
Website
www.fishgistics.com
Ok guys I got a problem with the piece. It starts and runs fine.
But when you give it gas and then let off it almost dies for a second and then it shakes a bit and idles fine again.

Any idea what could be the problem??

Its a 1992 V6

Go Big Or Go Home
 

Tomack

Well-Known Member
Joined
Apr 2, 2001
Posts
334
RDC Crypto
7
Location
Keller,Tx(Far from the desert).
change the fuel filter. and fill it up with gas and put some fuel injector cleaner in it. Might help the problem. Make sure and use some good fuel

"If you aint racin, you aint livin"
 

partybarge_pilot

Well-Known Member
Joined
Feb 19, 2002
Posts
6,850
RDC Crypto
1,684
Location
Easton, KS
It might be the TPS sensor. unplug it to throw the computer in defualt and see if it runs better. It won't run perfect but the stumble should be gone. I've had this problem in the past.
 

rdc

- users no longer part of the rdc family -
Joined
Dec 31, 1969
Posts
5,788
RDC Crypto
8
Yeah I would agree that it sounds like the TPS. Those are easy to check with an ohm meter. Might also be the air flow sensor. Same thing unplug it and see if the problem goes away. Or better yet I will trade you a ford which I know what is wrong with it.. LOL...

Tony
<A target="_blank" HREF=http://www.y-not-productions.com>www.y-not-productions.com</A>
 

toyoter91

Well-Known Member
Joined
Jul 20, 2001
Posts
300
RDC Crypto
0
Location
So Cal
Website
www.dordon.net
hey mine was doing that for a while too it would also bounce at idle. it was a vacuum leak. check all the hoses. hope this helps. oh yeah also it might be that Air is coming into the intake past the Mass flow. make sure thats all nice and sealed up tight. hope this helps


-Rob
 

Kritter

Krittro Campbell
Joined
Jun 18, 2001
Posts
10,914
RDC Crypto
299
Location
Chino, CA
get a can of carb cleaner and spray it on the hoses and check for vacuum leaks that way.



Kris
<A target="_blank" HREF=http://www.dmsrace.com>www.dmsrace.com</A>
"Jesus loves you, everybody else thinks you're an A-hole"
 

fishd00d

What A Joke
Joined
May 9, 2001
Posts
15,640
RDC Crypto
6,248
Location
San Marcos, CA
Website
www.fishgistics.com
Ok I just figured out that it doesnt really do it for the first few minuets when you start it. Its after it gets warmed up that it starts doing it.

I opened the MAS and everything looked and moved ok.

Go Big Or Go Home
 

toyoter91

Well-Known Member
Joined
Jul 20, 2001
Posts
300
RDC Crypto
0
Location
So Cal
Website
www.dordon.net
That is the same thing mine was doing. i will think back and see if i rememeber what i did. let me go check out my hoses to look at them. laters

-Rob
 

fishd00d

What A Joke
Joined
May 9, 2001
Posts
15,640
RDC Crypto
6,248
Location
San Marcos, CA
Website
www.fishgistics.com
Well I drove it to the desert last night and it was still doing it but then later in the night I noticed it wasent doing it anymore. Works fine now!

So I guess it just needed a good little beeting!

Go Big Or Go Home
 
Top