Truck Won't Start?!?

leftcoast650

New Member
i have a 99 ford ranger xlt the battery has been dead for awhile so i let it charge overnight and part of today and it holds a charge. so i just went to fire it up and the fuel pump starts to prime then just cuts out and the engine doesnt even crank. it flashes theft on my dash could it be because i removed both of the airbags? please help i would like to get it moved out of my driveway pretty soon.

Thank you!
 

socalmoto

Well-Known Member
The pump will stop after it primes, but it should be running when you try to crank. If your theft light is flashing it is probably the anti-theft cutting out your power. Are you using the factory key or a key made by a hardware store? The rangers (not sure exactly what years, but its in my 01) have a chip in the keys from the factory. If your computer some how screwed up, it could have forgot the chip id and youll have to take it into ford to get it back.
 

leftcoast650

New Member
The pump will stop after it primes, but it should be running when you try to crank. If your theft light is flashing it is probably the anti-theft cutting out your power. Are you using the factory key or a key made by a hardware store? The rangers (not sure exactly what years, but its in my 01) have a chip in the keys from the factory. If your computer some how screwed up, it could have forgot the chip id and youll have to take it into ford to get it back.
i know that the pump stops after priming but its not even on for the normal amount of time. and it doesnt even crank it just flashes theft. and i do use normal ford keys.
 

manicmechanic

Well-Known Member
Sounds like add on anti theft, A friend had it and I do mean had!!! on an explorer. The system just disabled the starter and set off the horn. Since the horn no longer worked it just wouldn't crank. Jumping the starter soliniod got it home after a dead battery. A jump start put it in anti theft mode, MAKE SHURE ITS IN PARK WITH THE BRAKE SET!!!. This setup had a remote to reset it, of course the remote had another dead battery. We tracked this thing down and got rid of it. I dont know if the rangers had factory anti theft as an option at the time. The factory stuff is not what you hear going off in parking lots all the time. Some aftermarket stuff is certainly better than others but those systems have stranded the owner more times than chrysler for chrys sake.
 
Top