white smoak

dcman008

Well-Known Member
Posts
140
Reaction
0
i got a "rebuilt" 20 for my toyota offraod only... and it blowing white smoak like crazy. if i let it run for about 2min my whole back yard is filled with smoak. ive checked the oil no water in it, water level in the radiator has not changed i also changed the exhaust thinking that there may be some thing in there. it also is giving off a windex kind of smell. what could it be, tomaro if i get time i will get some video of it to see if that might helps.

"on a scale of one to ten...i think im at least a bagillion!"
live long 91 cors-a-truck
 

fnkrngr

Active Member
Posts
29
Reaction
0
Let it run a little longer it may just be break in lube that someone used too much of.

You dont know the looks i get with this truck on the east coast.
 

ACID_RAIN28

Well-Known Member
Posts
1,409
Reaction
60
how long did it run? and it did not get hot. after i blew mine, and then fixed it, it blew white for a week, to get all the water out of the cat and muffler.

"Everything you do is triggered by an emotion of either desire or fear."
 

fishd00d

What A Joke
Posts
15,503
Reaction
5,435
Ya when we put the new motor in the General it smoked like hell for about 2 days when we first ran it...

Go Big Or Go Home
 
Posts
10
Reaction
0
Break-in lube..

but just keep an eye on that motor, my friend with a 65 ford recently found a freeze plug in backwards in his new 460. Motor also had one 460 head on it and one 429 head on it.. didn't run too well if i remember. People make mistakes.


Russ


Russ
www.rit.edu/baja
98 ranger 4x4 ext cab
71 cj5
 

tedmales

Well-Known Member
Posts
541
Reaction
10
is it smoke or steam, does it hang, or quickly dissapear. i have never had a toyota motor to break in but every small and big block chevy i have built never smoked anything like you described. is it an automatic. had a car come in one time with a vaccum line hooked up wrong and the engine was sucking transmission fluid out of the transmission.

life is too short to be small
 

Kritter

Krittro Campbell
Posts
10,914
Reaction
296
Did you put a new header on it? When I put headers on my truck the insides were caked with grease and the thing smoked like a banshee for 3 days or so.

Kris
<A target="_blank" HREF=http://www.barneysprecision.com/fabproducts.htm> Fab Parts</A>
 
Top